Adding deprecation policies to balena-sdk and CLI

We now have a deprecation policy on balena-sdk and balena-cli. If you or your teams use these modules, you’ll want to upgrade to at least one of the following versions:

  • balena-sdk (node) v12.12.0
  • balena-sdk-python v7.8.0
  • balena-cli v11.13.0

Please see our documentation for more details about the deprecation policy. We ask that you update the SDK or CLI modules to the latest version to ensure the best experience.

If you use an older version of the modules listed above, especially ones that have been out a year or more since this announcement, you might unexpectedly face issues.

Deprecating image maker endpoints

We'll also begin deprecating old image maker endpoints (such as https://img.balena-cloud.com/api/v1/device-types), which will have little to no effect on our user base. We plan on changing and/or remove them in the future without further notice. We encourage everyone to use our balena API endpoints, which you can learn about extensively in our docs.

Please get in touch with us on our forums with any questions or concerns.

comments powered by Disqus
Terms of Service | Privacy Statement | Master agreement | Copyright 2019 Balena | All Rights Reserved